Saturday, June 23, 2007

OK, time to switch back to castle. use "AOP" as a better synonym to "TDD"

I guess you can argue that EntLib 3.0 and Springframework are M$ and Java, and Castle is the golden middle.

However, in may aspects, the two extremes (M$/Java) have common styles, and castle is different because it is closer to Ruby or AOP style.

I know some may say TDD style. I agree, I believe the number one rule of TDD is actually pragmatic AOP ("you shall not repeat"). However, I do not believe many people realize that yet, including most TDD top guys/gals. So, I prefer saying AOP, instead of TDD. Also, I say "pragmatic AOP", to emphasize that AOP is not just about cross-cut concerns -- just like OOP is not just about inheritance. Further, real world AOP always builds up OOP, so, AOP contains OOP. In short, I am determined to use AOP as a better synonym to TDD.

The key? Castle has a better taste (aop taste), even just a little better, see my blogs in the past year. That is all. However, again, switch back and forth.


Post a Comment

Subscribe to Post Comments [Atom]

<< Home